[1246] Arabic glyph names not converted to production names on export

The behaviour has changed between 1230 and 1246, I get a number of Arabic glyph names in the exported OTF that even keep the hyphen in their name.


In the previously exported font, they had uniXXXX names.

I just tried with build 1246, and it is true that the two-dot glyphs lack their Unicode values, but the names are converted to a hyphenless version:


That unicode was wrong. The uniFBB2 is supposed to be used as a letter when a text speaks about a dot about a letter. So it not a combining mark and the two should not be mixed up.

The hyphen should be remove, and it is, if I export it.

The glyph names keep the hyphen when I export as OTF, but th hyphens are removed when exporting as TTF …

I also tested with an OTF in 1246. Are you sure you do not have custom naming enabled?

This is totally weird. Today the hyphens in the glyph names of the exported fonts are gone. The only thing I have done knowingly was to update the glyph info for the affected glyphs. That may have fixed it.

1 Like