2.5b new issues


#86

Good point. I fixed it.


#87

found the same "Undo: " problem when manipulating nodes with ctrl+alt+arrows


#88

Thanks for the report. I found a few more places with missing undo messages.


#89

can’t decompose on the background


#90

can’t decompose in the foreground either

23


#91

I’m working on a typeface with 3 axis (Not sure if that’s the reason). The thing is the drawing of the Light master is affecting Bold and ExtraBold instances. It is not supposed since I have a Semibold Master. Just on 2.5. On 2.4.4 it works correctly:

2.5:

2.4.4

I supose it’s a 2.5 bug, right?


"Fix a bug with interpolations in certain setups"
#92

Then you have unusual master definitions. I just tried it and it works fine for me. Can you post your master setup?


#93

Sent to support, ok?


#94

Cannot reproduce in latest 2.5b :man_shrugging:


#95

What do you mean with cannot reproduce? Reproduce what?


#96

isn’t this happening to you?

interpolation.zip (1.2 MB)


#97

Same file:
2.4.4 on the left. 2.5b on the right. (>Semibold instance)

Can anyone help me finding out what’s wrong with my master definitions? Because I can’t. :confounded:

glyphs file:
Glyphs-interpolation2.zip (15.0 KB)


#98

I have a look. Your master setup is indeed OK. I have to investigate this.


#99

One thing you can always do is to use the “Disable Masters” custom parameter for those instances that require it. If you do not want the Light master to be used in certain instances then you can suppress it with the help of this custom parameter.

In some cases, this is interesting to play around with in any case and often you will need to visually judge whether disabling a master (and which one) leads to the most convincing results. Sometimes – particularly for extrapolations – it’s a tough call even for us designers, which suggests that it is forgiveable if the default, automatically selected mix is not always what we prefer.


#100

Thanks @GeorgSeifert! :+1:

Thanks for the tip @TimAhrens. I definitely have to try it.


#101

Thanks for reporting this, Francisco. This is clearly a bug and I have fixed it (in the code that determines the interpolation). Should be updated in one of the next Glyphs versions.


#102

I’m glad to know that @TimAhrens!


#103

This is fixed in 1129. Thanks Tim for fixing it so quickly.


#104

This was driving me crazy too (losing corners/caps when choosing Remove Overlap from the menu). But I did figure out that the remove overlap path operation button (left bottom in Transformations palette) keeps them.


#105

Hi there,
I also seem to have have an issue with this version (I have 2.5.1, mac OS 10.9.5).
Width and Custom text fields are missing in the Master panel in Font info.
When I click on the (?) the message “Add more axes in” appears but without any effect.
Or I am missing something? The composition of the fields on the window looks weird too.