[3181] Weird editing behaviour in text mode

SInce the last update, something is broken in text tool.

When you type some words, and press enter, the linebreak will be added before the previous word, not at the cursor position.

When I have multiple lines with just two glyphs, and I click to set the cursor to the end of the line, it is inserted at the beginning of the line instead of the click position.

It’s hard to see in the video without seeing the key presses, but you get the idea.



I would like to add that this seems to have something to do with the space character, as this doesn’t happen with just “normal” characters in the line string.

So just typing “Hand[return]gloves” works, but typing Hand[space]gloves[return]" will push “gloves” to the new line, like in Jens’ screen capture.

I fixed that already. I did some refactoring on the layout code and missed that.

Hi, I know you hate getting “when update pls”, but… when update pls? This bug is extremely annoying, as it makes working in text mode with line breaks nearly impossible (for example, working with Kern On, going through model pairs).

update is out


Thank you very much! Works again.

Hello, I’m sorry, but on my Mac Mini (Ventura), the behaviour is still the same in 3182. It works on my MacBook on Monterey.

Typing “Hand gloves” and hitting return shifts “gloves” to the new line.

What you describe is the expected behavior. What specifically is not working?

There was a problem that the gray return sign was going to the next line, too. That one should be fixed.

What I mean is that if I type two words separated by a space, and then hit return, the last word is put onto a new line. Is this really the intended behaviour?

To illustrate, this is the behaviour in 3182 Mac Mini 2023 Ventura:

Screen Recording

At the end, I am clicking to position the cursor at the end of the line. The return is visible at the end of the line, and if I hit Del (Entf), the line jumps back to the top.

1 Like

I see. Thanks for the illustration.

fixed it.

This seems to be back in build 3203 …

1 Like

Fixed, again.

not fixed for me. 3203

3203 did break it :wink: