4 axes Variable font issue

Hello everyone.

I have a problem with a font I am developing.

Problem ā€“ When font is tested in Illustrator or Font Gauntlet only 3 axes work. If I push all 4 axes sliders it seems to go back to the default master.

The font has 4 axes added in the custom parameter info (weight, optical, ascender and slant)

41

The font consists out of 16 masters. The masters have 2 weights (Light and Black), 2 optical sizes (One, Four), and 2 ascender sizes (A, E). I use a scale from 0-1000 on all axes except on slant where I use 0-12.


The problem occurs when I test it outside of Glyphs, in Illustrator, Axis praxis or Font Gauntlet (tested in Safari an d Chrome). When I move all the sliders to 1000 and slant to 12 it seems to go back to the default origin master. I have also tried to set a custom Variable font origin but I have the same issue. When I am doing the testing with instance slider plugin everything is working fine. My Glyphs version is 2.6.2 (1267)

Here is a gif of what is happening.
It seems to go back to the default master but it looks completely broken, as if it is extrapolated.

Gauntlet_test

If anyone has some ideas I might try I would be grateful.

1 Like

Sorry for the delay, I must have overlooked your posting. Exporting 4 axes is currently still unreliable in Glyphs, and your project seems to be affected. It is an issue high on our list though.

3 Likes

I believe I may be experiencing something very similar to the above post. Iā€™m curious if exporting 4 axes still unreliable?

The next version has no limit on the number of axis any more.

1 Like

Hi! Iā€™m having problems exporting 4 axes variable font from latest Glyphs 2,
this is what I get if Iā€™m not aligned with the origin on all 4 axes:

Tried changing the origin, and one or the other location gets distorted anyway. The instances / static fonts are fine.
Is this a known issue? Any chance it might get fixed?

Glyphs 2 only supports up to three axes.