"8" Glyph not compatible for variable. Trouble setting up document for axes width

Hi I am having trouble with getting my 8’s to be compatible and I wanted to make a variable font with a condensed version, I think I am setting the file up wrong.

I got the 8 but still not sure what is wrong with my width version

Have you read the tutorials about master compatibility?

https://glyphsapp.com/tutorials/multiple-masters-part-2-keeping-your-outlines-compatible
https://glyphsapp.com/tutorials/creating-a-variable-font
https://glyphsapp.com/tutorials/multiple-masters-part-3-setting-up-instances
I read these

  • Compatibility View and Fix Compatibility should help you.
  • I have a suspicion that you have duplicate outlines in one of the masters. The Show Angled Handles plug-in from Window > Plugin Manager should help track those down.

How about setting up for width, if I get anything it doesn’t change at all.

Am I doing something wrong?

  1. For one thing, it looks like you opened and imported an existing font. Consider reading the Importing Existing Fonts tutorial. You can get rid of most of the parameters.

  2. The Axes parameter goes into Font Info > Font, not Masters.

When you are uploading screenshots, can I ask you to make your window smaller, just big enough that it shows the content we need to see, and then take a screenshot of just that window (i.e., not the entire screen):

  • first Cmd-Shift-4 to trigger the screenshot,
  • then press the space bar and click the window you want to screenshot, and upload that. (Pro tip: hold down Opt & Ctrl when you click the window, then it will be put in the clipboard without window shadow, and all you need is to paste here.)

That will make your screenshots much easier to read.

Thank you so much!