A plugins are causing crashes

Hello everybody,
It’s been a while since I used GlyphsApp. I’m getting a similar error for every plugin that I installed via Plugin Manager:

I think it could be caused by me doing some crazy stuff with having two MacOs Users on the same computer (one for fun activities, and the second one for work).

How can I fix this?
My MacOS is 10.15.6 Beta and Glyphs version is Version 2.6.5 (1340)

Best,
R

What python version do you use? Glyphs 2 only works with the system python 2.7.

2.7.16. But I do have installed a lot of instances of python from home-brew as well as virtual enviroment.

By default I added a bash script (something like source ~/.venv/myPython3/bin/activate), which activates one of my python 3.8 environments.

When I deactivated it, and returned to python 2.7.16, I still get this error message.
Here is the output from my terminal which shows what python am I using right now.

$ which python
/usr/bin/python

$ python
WARNING: Python 2.7 is not recommended. 
This version is included in macOS for compatibility with legacy software. 
Future versions of macOS will not include Python 2.7. 
Instead, it is recommended that you transition to using 'python3' from within Terminal.

Python 2.7.16 (default, May 16 2020, 02:22:12) 
[GCC 4.2.1 Compatible Apple LLVM 11.0.3 (clang-1103.0.29.20) (-macos10.15-objc- on darwin
Type "help", "copyright", "credits" or "license" for more information.

this is default python 2.7 that came with macOS stored here /System/Library/Frameworks/Python.framework/Versions/2.7/lib/python2.7

It is actually caused by a newer version of PyObjC.
what do you get when you run this in the macro window:

import objc
print objc
<module 'objc' from '/Users/MyUserName/Library/Python/2.7/lib/python/site-packages/objc/__init__.pyc'>

it should read:

<module 'objc' from '/System/Library/Frameworks/Python.framework/Versions/2.7/Extras/lib/python/PyObjC/objc/__init__.pyc'>

ok, solved by deleting some third party python that somehow default’s python sys.path was linked to and has been overriding the original modules. Btw, is new Glyphs will also use default system python? it seems a bit dangerous. It would be supercool if Glyphs user could point to the virtual env, which would be used later in Glyphs.