A problem occurred message

Hello, I got a message during working. So I am posting it here.

Please help us to fix it by copying the following text and pasting it into a new post on https://forum.glyphsapp.com. Thanks!

text: '쓰유쓔이위스이써헬민국카자산한민국카티대글로미리마이너주로프민년주념기적디민인위의교인표적스막카딩거가 에주두아로르트' (__NSCFString), length: 59, string: '' (NSConcreteAttributedString), length: 0, range: {60, 0}


-[__NSCFString replaceCharactersInRange:withString:]: Range or index out of bounds

    "3   CoreFoundation                      0x00007ff80ebff1fb mutateError + 121",
    "4   CoreFoundation                      0x00007ff80eb513a2 -[__NSCFString replaceCharactersInRange:withString:] + 50",
    "5   Foundation                          0x00007ff80f9c8aea -[NSConcreteMutableAttributedString replaceCharactersInRange:withAttributedString:] + 346",
    "6   Glyphs 3                            0x000000010c30bff6 _ZN7plcrash2MS5async35plcrash_async_dwarf_expression_evalIyxEE15plcrash_error_tP21plcrash_async_mobjectjPK26plcrash_async_thread_statePK25MSplcrash_async_byteorderyxyPT_mSD_ + 342470",
    "7   AppKit                              0x00007ff8117735d3 -[NSTextInputContext(NSInputContext_WithCompletion) insertText:replacementRange:completionHandler:] + 176",
    "8   AppKit                              0x00007ff811f2209e __55-[NSTextInputContext handleTSMEvent:completionHandler:]_block_invoke_2.354 + 102",
    "9   AppKit                              0x00007ff811773515 -[NSTextInputContext do_HandleTSMEvent_insertFixLenTextLoop:whileCondition:dispatchWorkEach:afterEachInsertText:continuation:] + 105"

Any context? Is this displayed in the Macro Window? Or is it a popup? Were you trying to use a plugin?

I just had the same error. Tracked it down to an illegal glyph name (empty). Once that was corrected the error did not occur again.

Can you recreate the file and state that created the error?

:slightly_frowning_face: Unfortunately not. I don’t know how the glyph without a name came to be. I only discovered it by looking through the glyphs after seeing the same error message as the original post.

And you don’t have that file anymore?