About a text in v2.3

The .glyphs file of the old version converted a text into Unicode Escape Sequence.
text = "\U30D5\U30A9\U30F3\U30C8";

This changed in v2.3.
text = "フォント";

Is this specifications change? Or bug?
When the file of v2.3 is opened by v2.2, all Non-ASCII characters are garbled.

“©” of Copyright is garbled, too.

Glyphs 2.3 does not escape Unicode characters to make it easier to edit and read the file.
Why do you need to open it in 2.2?

I think that non-escape is easy, too. It is sure that this is improvement.
One of the users who tried v2.3 uses v2.2. She is dissatisfied with v2.3 a little. Tosche will explain the details. :grin:
I made software to repair the file which saved this mojibake text for some users. I wanted to know the range where this software would be required from now on.

I usually check whole image of glyphs that are made using the font window.
But when I updated to v2.3, the glyphs aren’t in line correctly.
I guess that the empty glyphs are correct, so made glyphs look too down.
That’ why I was back to v2.2 from v2.3, and then the Japanese text was broken.
Could you fix the problem of the row in the font window?
(monokano-san still fixed the broken Japanese text.)
If it isn’t solved it, it’s difficult to update to v2.3 for me.

By the way, there is another problem in the vertical window.
I found the problem from v2.2. But this error hasn’t been fixed in v2.3.
Because when I enlarged a screen, I can’t scroll the glyphs to the direction of the left,
I can’t see the whole of them.

There are big problems when I use glyphs so far.

Because I’m bigger in this forum, I can’t upload some sample images.

Can you send me a screenshot from both versions explaining the difference in positioning?

Okay, I post them.
(Because it’s not consecutive posting, I think I can do that.)

The glyphs don’t in line

I released App “Fix Mijibake for Glyphs” to fix a .glyphs file which saved this mojibake.