About GlyphsPythonPlugin problem

Due to network issues, the Python module cannot be installed from the plugin manager, but it can be downloaded from the GitHub - schriftgestalt/GlyphsPythonPlugin: Python runtime packaged as a plugin for Glyphs, but directly placing it in the Repositories does not recognize it. May I ask What other actions or settings are needed to make Glyphs recognize it?

When you download it manually, macOS places the files in quarantine that prevents it from working in glyphs.
In your case it is easier to download python from python.org and the install pyobjc manually (using pip install pyobjc)

Then check if the installed python is selected in Preference > Addons > Python Version. (You need to restart Glyphs after you installed python)

I know this method, but some people operate it like this and Glyphs crashes as soon as it is opened. When only install python and pyobjc is not installed, Glyphs can be opened. When Pyobjc is installed, it crashes as soon as it is opened.

Please update to the latest version of Glyphs.

And try to open Glyphs without loading plugins by holding the Option and Shift key when you start the app.

Older versions needed pyobjc 8.4 and not later. Details on the Extending Glyphs tutorial. Or better, update to the latest cutting edge version.

It latest version of pyobjc should be fine. I suspect an outdated plugin.

It really has nothing to do with the Pyobjc version. He initially installed version 9.2, but I thought it was caused by a high version. So I asked him to reinstall versions 8.1, which still caused the crash. It’s not related to plugins either, because they haven’t started installing plugins yet.When the plugin manager installed the module, there was only Python that couldn’t be successfully installed, so I used it to let him install Python himself and haven’t started installing any plugins yet. Maybe it’s related to the glyphs version, I’ll ask him to update the latest version and give it a try.

Can you remove the (partially) installed python module from the Repositories folder?

There is no Python module in the Repositories folder, it was not successfully installed from the plugin manager, constantly prompting
Failed to clone repository fromhttps://github.comschriftgestaltGlyphsPythonPlugin

Did you update to 3.1.2 or better to 3.2?

And please send all crash reports from the window that comes up when you restart Glyphs.

I had the same problem after I installed the glyphs 3 on my new laptop. The python script couldn’t be installed, tried many times. However, it get solved after I installed homebrew and then use homebrew to install python… maybe you can try it too

When the glyphs python module fails to install, it should help to manually remove it from the Repositories folder.