Adding custom glyph to existing font

Okay I’m trying to add a recurring small caps word to a font that doesn’t currently have small caps. I don’t need to design the whole small caps alphabet, just one word that happens quite a few times. I designed this glyph, and now when I try exporting, it’s not showing up in my Adobe apps. I’ve tried following instructions from other posts, including creating an adobe fonts folder and saving to that, as laid out here. Unfortunately it’s still not showing up. Any suggestions? I’ve tried naming it something different in order to see if it’s cache related, or just straight up not working, but any time I try to export it under a new name, it just reverts back to the original name so not sure how to check using that method.

*Using Glyphs 3

When I have had this issue, it always seems to be because I missed to delete some “Local Family Name” parameter. There are such parameters under both the “Font” tab and the “Exports” tab in Font Info when opening an OTF.

And also of course the usual stuff of closing all software and uninstalling all versions of the previous font before the new installation.

Okay thank you. Yeah I had tried the closing software, removing old font, etc. But didn’t consider the parameters you mentioned, I’ll have to look more into that. Thankfully, my client was fine just buying the right font that does have small caps, so this issue is for another day. That being said, I still wanted to be able to achieve this haha

What I would do:

  • verify write access to the Adobe Fonts folder
  • verify if the file gets written at all; if yes, take a peek in the OTF with OTMaster or FontTableViewer
  • verify the family name(s) in Font Info, perhaps it was overwritten in the instance