All styles look alike under Windows 10


Please help me!

I would like to finish my actual project. This is a layered script font, with 8 styles.
Yesterday I tried to test under Windows 10.
After installing, the font preview under "Control Panel” show all styles look alike.

More precisely: Which style I installed for the first time, all the rest looks the same. :frowning:
(All 8 styles are guaranteed to be different.)
What can be the cause of a mistake?

Glyphs version: 2.5.2 - 1165

Thanks in advance.

Do you have special naming settings? Did you read the Naming tutorial?

Thank you, for quick answer.

I don’t think so. I don’t use custom parameters for naming.

Yes, even earlier. Because I tested under Windows 7, I got error. “Not valid fonts.”
After I changed to the shorter names.

Yesterday I came to Windows 10 testing. The installation was successful.
So far it seems, all 8 fonts working good under Windows 10.

But because the preview is wrong in “Control Panel/Fonts”, I think something is wrong.
All other installed font styles preview is good. I can’t figure out what is the problem.

This is interesting. I installed the Glyphs Sapperlot layered demo fonts.
I got same results. (I tested two different computers.)

Solved. :slight_smile:

What was it?

I added for each styles a different weight value.


weightClass you mean? Like 400, 500, 600, etc.?



1 Like

Could you send me some of the broken fonts? I need to have a look.

Yes. Which format? Glyphs or otf?