Alternate Layers Variable Not Working in Ai

I’m exporting an eight master family with Weight, Italic, and Width axes as a variable font. I’m using alternate layers (bracket layers) to fix some glyphs in the heavier weight ranges, but they aren’t working for me in Adobe Illustrator. They’re working fine in Font Gauntlet.

I’m using the following alternate layers for each master, as show in the screenshot:

I’m running version 3.0.4.

Any idea why it might not be working in Ai? Any help would be greatly appreciated!

Can you try in a Browser if it works there (e.g.
There where several threads about this: e.g.: Alternate/bracket layers not working on Illustrator - #5 by ferfolio

1 Like

Apologies for duplicating topics.

Yes, they’re working on Font Gauntlet.

To fix weight issues like this you should try brace/intermediate layers. No need to switch out the whole glyph. And usually you should be fine with one intermediate layer. Draw the Bold master that it looks good and add an intermediate roughly at the Semibold.

1 Like

@GeorgSeifert I’m having this same issue. The fonts works in other Apps and Font Gauntlet just not in Illustrator. Is there something wrong with my set-up and if so, how exactly should it be done? Thanks!

If it works everywhere except Illustrator it is most likely a problem in Illustrator that can’t be solved with the font. There seems to be something with the setup of Illustrator that breaks it because most files that people send me worked fine for me. Can you remove all fonts from the Adobe fonts folder and the system and restart your mac. Then export the font again.

I’ll try that. Oddly, an older font I made in Glyphs 2 that uses bracket layers works fine in Illustrator (tested in v.2021 & 2022).

There are several threads that discuss this. Search for “Illustrator”.

tl;dr: Glyphs uses the rlig feature for the feature variations. That seems to not work sometimes. Then there is the rvrn feature. It might work better in some instances but can’t handle alternate glyphs (like small caps). So I strongly recommend to not use it.

Thanks Georg. Changing the Feature for Feature Variations custom parameter to rvrn made the alternate layers work again so I’ll stick with that for now. Does anyone know if this bug has been submitted to Adobe?

Which version of AI are you running?

I’m using Ai version 26.2.1

26.2.1 for me also.