Alternates not working - Font imported from Mini to Glyphs


.aalt/.ss01 features don’t seem to be working for me. I was working on a trial version of Glyphs Mini when I realized Mini doesn’t support alternates so I downloaded Glyphs and imported the font I created on Mini to Glyphs.
I have already created a few alternates but when I export it, it doesn’t work automatically.
I even tried going to Features and updating it, but it only shows the ligatures.

Would love any help.

Did you Update the features in Font Info > features?

As I mentioned in my original post, I did update it. But it only really shows the ligatures and nothing else.

What are the glyph names of the alternate glyphs?

What are your alternate letters called? If you want an alternate a, and a working feature, you need both a and a.ss01.

I have all the glyphs and I have alternates for a, g, r, t. I named them a.ss01 and so on. I even tried a.aalt.

I can’t seem to get any of them to work or get updated in the features.

Sorry, I meant l, g, r, t. Uploaded screenshot above. Also, when I names them g.ss01 etc, they were put in ‘Letter, Latin,’ as can be seen in the screenshot.

If you hit the ‘Update’ button in Font Info > Features, you should get an entry ‘ss01’ in the sidebar.
The export the font again. Please read those two tutorials:

.aalt is not what you want, you want .ss01. The available suffixes for feature automation are listed in the handbook’s appendix.