"Always center active glyph" preview bug

Hi, I can’t seem to deactivate “Always center active glyph” in the preview pane.
Right clicking to disable doesn’t do anything.
I’m on the latest cutting edge on latest Monterey.

If you have only a few glyphs in the edit view, there is no difference between the two options. Only if the preview gets filed up, it will make a difference.

So is this normal behavior? Dropbox - Untitled.mov - Simplify your life

The jumping around is not intended. What version of Glyphs do you have?

The intended difference for that setting you can see when you move the cursor to the first letter, then that letter is either on the left side of the preview or the middle, depending on the setting.

I have 3.0.5 (3112).
I thought that the full previewed content would be centered with that setting off

This issue is still present in the latest cutting edge (3180)