Annotation Tool

Hi!
Can anybody please tell me how to activate the annotation tool?
I just don’t get it. Any clues? Thanks in advance!

It’s explained in detail in the handbook. When working on a letter, just click the button (shortcut is ‘A’), then you pick one of the options at the bottom.

Thanks Mekkablue, but ich stehe auf dem Schlauch : )
When I hit ‘A’ nothing (visible) happens. Which Button should I click instead of using the shortcut? I can’t find this little Icon shown in that particular chapter of the handbook anywhere in the App (this little notepad-icon).

Which version of Glyphs are you using? Glyphs Mini doesn’t have it and the AppStore version doesn’t have it yet.

Ah! OK! I’m using 1.3.15 (AppStore Version). Then I guess I’ll have to wait for that feature. Thanks again!

Jetzt stehe ich auf dem Schlauch…
Version 1.3.15 should have it… Perhaps you want to try reinstalling it from scratch.

Same here, I can’t see anything happening when hitting A

do you see the gray info box in the bottom of the window? Check if View menu > Show Info is checked.

@ Georg: Yes I see the info box. Nothing happens with that box when I hit A. Or a. Every other shortcut works.

@ mekkablue: I deleted the app from the application folder and installed it from scratch via AppStore. Still nothing happens.
Any Ideas?

I also installed Glyphs both on my old and my brandnew Macbook Pro. But the annotation tool still don’t work on either machine.

(But Glyphs is still a great app, nevertheless, Georg : )

You don’t see this icon in your toolbar?

Annotation tool

Go into Finder, hit Cmd-Shift-G and paste this in the dialog that appears and hit return:

~/Library/Application Support/Glyphs/Plugins/

A folder called Plugins should be displayed. What do you see in there?

Nope, I don’t see that Icon. Plus: I don’t see that little anarchy logo on the right. What’s that good for?

And I hate to say that, but there is no Glyphs Folder (and therefore no Plugins) in my application support folder. Neither on my old Macbook, nor on my new.

Anarchy Icon is Yanone’s great SpeedPunk plugin.

Honestly, I don’t know what causes the lack of the Annotation tool.
Which system version are you running? 10.6, 10.7 or 10.8?
Have you tried it in a different user?
Can you download the trial version and run it (from the Downloads folder should do) and see if it is missing there too?

There must be a Glyphs folder, though. What happens if you go into the menu Script > Open Scripts Folder?

I am having the same issue.

If I open my scripts folder it opens here:
~/Library/Containers/Data/Library Application Support/Glyphs/Scripts/

The plugins folder is there as well, but only plugins are the ones I installed (RMX and TraceBackground)

I’m on 10.6 using version 1.3.15 (413).

Hey there. I'm curious, that icon on the far right (anarchy symbol?) - I don't think I have it. If I may ask, what is it?

Edit: Nevermind. I should stop skimming text.

Sorry, I made a mistake. I was looking for the scripts in the general Library/App Support. Just found out its in the user library.

I’ve made some tests.

Old Macbook Pro OS 10.6.8:
When I open a brandnew downloaded trial version, at least I get the annotation tool. The Speedpunk Icon remains invisible.

if I open the scripts folder the path is
my-user-folder/Libary/Application Support/Glyphs/Scripts
(scripts is empty)

New Macbook Pro OS 10.8.2:
(would be glad If it would run properly on this machine…)

I deleted the App (including hidden files). Then installed it anew.
Both features (Annotation & Punk) remain invisible.

When I open a brandnew downloaded trial version, at least I get the annotation tool. The Speedpunk Icon remains invisible. (Same as old computer).

The path to scripts is
my-user-folder/(hidden library)/containers/com.schriftgestaltung.glyphs/Data/Library/Application Support/Glyphs/Scripts (scripts folder is empty)

sigh…

@Juergen
Do you have the App Store version or the one from my site?

Can you have a look at the Console.app and check if there is any output from Glyphs. If so, can you send it to me by email?

You need to manually download and install the Speedpunk plugin.

Georg, I sent a mail at info@. Thanks for looking at it.
It’s a appstore version.

I just checked it and for some reason, the Annotion tool is missing from the App Store version. I have no clue how this happened but I will fix this soon. I have to fix a few smaller things before i upload a new version. But this will happen soon.

OK! Than I guess I’ll wait for an update!
Thanks eyerybody!

I have this exact same problem.

Version 1.3.15 (413) bought in the AppStore.

System 10.7.5
Tried on 10.8 on my MBP. A trial on that mac, 1.3.11 has the annotation tool.