App Glyphs 3 crashes

I am having trouble withy app crashing
I have restarted my Mac(Catalina 10.15.7) in safe mode
I have restarted it in a normal mode.
I open my glyphs app.
I select my file and open
I go to info and try to access my info.
The info dialogue box shows no info or image, just a white blank.
i touch the info dialogue box and
the app crashes.
Please advise.

What version of Glyphs do you have?
Did you send some crash reports?
Do you have any plugins installed. Can you start Glyphs while pressing the Option and Shift Key to disable plugins?

I am using glyphs 3.0.3 (3091)
I did send a report a few days ago for some help
I have un-installed all plugins
Restarted app with opt-shift
Still crashed.
I think I might have a corrupted file on my hands.
I tried to re-name it but that didn’t work.

Can you try the latest cutting edge version?
Activate it in Preferences > Updates > Show cutting edge versions.
Or you can download it here:

Ok I will give it a try . i will let you know how I make out.


Jim H

I downloaded the cutting edge file and this is the results

And then comes the crash.

Can you send some more crash reports and the .glyphs file?
And what happens if you do the same with a new file?

I have attached my trouble font file as you requested.
I can open and work on other files with my app and it works out fine.
I did send you some info earlier but it seems to have gone walk about.
I am using Cutting edge version to see if this helps. But this file does not want to co-operate.

Biggy font.glyphs (382.0 KB)

I found the problem. The crash is caused by the name of the axis. It is 100 and that was interpreted as a number and this is causing problem. I’ll fix it. You could open the .glyphs file in a text editor and change the name to a string (‘hundred’ would work).

Thanks for the update.
Please clarify for me if you
will be sending me back the fixed file, or,
if not clarify for me how i change the text edit info attached.

I’ll send you the fixed file.

And you REALLY need to close some tabs, once in a while. I recommend to not have more than 10 or so. You had 420! That slows down Glyphs quite a bit.

Hello Georg
I just re-read some of the manual and have discovered I am my own worst enemy when it come to tabs. From now on I will only type the
name (or words ) of the glyph I want to work on.
Much appreciate the advise. It might even save me so time.

Hi Georg, I tried installing Mekka plugins over the weekend and now can’t open a Glyphs font file, even after trashing the app, redownloading, opening the license from my Desktop, but keep getting crash reports (I sent a few). The re-open button simply blanks out.
Cannot download or update Glyphs? | Glyphs

I’m not actually sure if the plugins downloaded. I did take screenshots of the AppSupport folders (Plugins, Repositories, Scripts) I can send. Glyphs does open briefly to let me start a new file but I can’t open existing font files I created over the weekend — continually crashes those.

Kind regards, Tania

To find out if it is a plug-in, hold down option and shift keys while the app starts.

I held down Shift Option while opening Glyphs from the Applications folder, still get these crash boxes and shut down. I can open a working Glyphs file momentarily but it shuts down. Wayne is able to open my Glyphs file on his Mac. I was able to open a file to screenshot the Plugin folder, can you see the screenshot I attached

Screen Shot 2021-09-21 at 10.09.19 am

I see you are using Big Sur. Could you add a new user account on the Mac and try to open Glyphs from that account?

1 Like

Can you send me that file? It seems to contain a invalid reference to a image file. I like to have a look at this.

1 Like

Hi Georg and Florian, the 3098 version of Glyphs is working great. Thank you for your help. Kind regards, Tania

1 Like

hi everyone, today i just tried to open a .glyphs file i made in glyphs 2 and glyphs 3 just crushed, i tried everything, reinstall, update with cutting edge versions, uninstall with apps, reinstall modules, scripts, plugins but nothing works, now i can only open .otf files but not .glyphs ones, idk what to do, pls help