Applying a single stylistic set to several weights

I’ve created a stylistic set that is to be used across 3 weights without changing appearance. I’ve designed it inside the Bold weight. Is it in some way possible to use these components in the medium and the regular weight as well, or do I have to manually copy the glyphs over to the other weights?

Could you be a little more precise please? I am not 100 sure what you are doing and what you are trying to do. Here is what I am guessing:

  • “created a stylistic set”: Created alternate glyphs?
  • “across 3 weights”: You have a multiple master setup with three masters in one .glyphs file?
  • “designed it inside the Bold weight” = You created outlines only in the third master?

If the other masters are empty, it cannot interpolate. There is also a script for that in my repo, called Fill up empty masters.

Yes, I’ve created an array of alternate glyphs in a multiple masters setup. And yes, I created the outlines in the third master (bold) only which has to be used unchanged in the medium and regular weight as well. Now, the glyphs are empty in the medium and the regular and I want to find the best way to “fill” them. Hope that makes sense.

  1. Select all the affected glyphs in the Font tab.
  2. Switch to third master, and copy.
  3. Switch to other master, and Paste Special (hold down Opt key when you paste), choose content of active layer and perhaps some of the other options if they apply.

Or use the script I mentioned above.

Ah, smart! was unaware of this method. Thank you :slight_smile: Will have a look at the script as well.

Neither of these methods appear to work when the source glyph is made from components. Is that correct?

Copying and pasting components within the edit window works, but it doesn’t copy over the character width.

The original glyphs must be pasted as well. Otherwise the components reference nothing.

The original glyphs are in there. For example, I made a semicolon out of a period and comma components in the regular. The bold also has a comma and period. From Font view, I copy the glyph, switch to Bold, Paste Special and check “all data”. Nothing.

All Data pastes to the same layer. You might like to try ‘Content of selected Layer’.

Mine says “content of active layer” but that worked – the component pasted in AND it kept the character width! Unlike copying and pasting from the edit window (which really should pasted the character width, FWIW).

thanks,

John