Auto alignment problems when updating Glyphs 3

Hi, when using the latest cutting-edge builds of Glyphs 3 I often get the window stating that “This file was last edited in an older version of Glyphs and contains compounds with unspecified alignment.”

For example, the following screenshot shows /Lcaron as drawn in Glyphs build 3113:

Upon opening in build 3116, automatic alignment is disabled, regardless of whether you check the box or not. And despite disabling automatic alignment, the accent shifts to the left (probably by the claimed 105 units):

Upon re-enabling automatic alignment, the mark moves back to the right, presumably exactly to where it was before; see the screenshot on the right.

I am confused. I know there have been differences in the way Glyphs handles automatic alignment between major versions, but presumably nothing should change between minor releases, is this correct?

I know we are playing with fire by using cutting-edge versions for production work.

Two things seem to be going wrong here:

  1. Glyphs believes that the automatic alignment has changed when it hasn’t
  2. The check box “Keep selected” has no effect, forcing automatic alignment to be disabled.

Is there a known bug in a particular build (or builds) of Glyphs that we should avoid when using the cutting edge versions?



Can you send me that file (in the state as saved by version 3113)?

Thanks, Georg. I’ve sent it to you via email.

It is caused by the file containing positions for the components that are out of date (maybe you moved some anchors?) When you open the file in the old version and look at the Lcaron in all masters (that will trigger an automatic alignment), save the file and open it in the new version, it will not show an issue of that glyph any more. The auto alignment should run just before saving but that sometimes doesn’t fix this.

Thanks. Is there an easy way to trigger a refresh or recalculation of the coordinates for all glyphs (in all masters) at once? There are literally hundreds of glyphs whose positions have apparently shifted.

Why doesn’t version 3113 complain when I open the file? Has something changed since?

Also, is there a reason why checking the “Keep selected” box makes no difference? Thanks!

You can scroll through the full font in Font View for each master.

1 Like