Autohinting problem

Hi, I keep getting this message
Knowing I did not hinted my font, If I uncheck “Autohint” in export dialog, everything works. As far as I remember, the only parameter I changed wad the grid/subgrid values in font info. I have corrected paths direction, tidy up paths for every glyph in the file, still getting the error, any help?

Thanks in advance.

Different start point sometimes helps, and shifting the glyph a few units. Otherwise, you can exclude it from autohinting with a Disable autohinting for glyphs parameter.

I’ve tried to shift the position or change the start point but got the same result. For the parameter, I used it already for other glyphs but the problem itself is strange to me because it was the first time I encounter it. It seems to happen after last update I think.

The autohinter has been moved to 64 bits. Perhaps it is more picky now. Best option is to simpy add PS hints in the glyph’s first master layer.

Can you send me the .glyphs file?

Done, file sent in DM.

It’s happening to me, too, but with other glyph. As far as I can remember, I have every parameter set right, correct paths direction and tied up paths.

1 Like

Just chiming in to mention it just occurred for me as well. Not sure what I did differently, but occurred after updating to the most recent version. I also tidied paths, correct path directions, etc.

Found the problem and fixed it.

1 Like

Good, thank you.
We should update I think?

I’m about to upload a new version.

1 Like

The problem with autohinting glyphs while exporting the font is still happening, even after the latest update.

Same issue after update.


Any news about this?

1 Like

On my end, it seems to work on some files now, but not all of them.

The autohinting should work now. If not, please send me a file that has problems.

I’m getting this error, although in my case it is with a corner component rather than a glyph in the font. Is there a way I can fix this?

There was a problem autohinting the glyph: _corner.serif

What version of Glyphs do you have?

And you might set that glyph to not exporting.

v3.1. Yes setting it to not export solves the problem. I had missed that the component was set to export. Thanks.