Automatic Alignment for quoteleft and quoteright?

I have Automatic Alignment enabled in preferences, but it doesn’t appear to work for quoteleft and quoteright glyphs. It also fails for a number of others including: exclam, question, period, bracketleft and bracketright, etc.

EDIT: according to the handbook, “Non-letters are not automatically aligned.” Is there a way to force “non-letters” to automatically align?


1 Like

Can you please file a feature request at

Sure thing Georg!

I fixed it. Now you can enable alignment for all glyphs.


Awesome! Is this in the cutting edge version?

In the upcoming cutting edge version.

Enable Automatic alignment , restricts horizontal shifts but enables vertical ones for Non-letters; Shouldn’t it lock both!?
In that regard, I wonder if there is a way to reset components to their original position (instead of relying on the visual indicator (¬) for positioning)

What exactly are you trying to do? Which glyph with which components are you trying to auto-align?

The problem it that for none letters, the vertical position is not as easy to calculate. It needs to know if flipped at the cap-height or x-height.

Convincing ,
Thanks Georg

What if non-letters would flip around their own center or keep the same origin.y (to avoid rounding errors)?

That would move all components if you change the bonding box. And that can be unexpected.

Maybe there could be added an option to choose the auto alignment origin?

There already is the “*origin” anchor. But that doesn’t help with the rotation.

1 Like