Axis Mapping not exporting properly

I am working on a new typeface and am messing with axis mapping for a curved weight distribution. When I go to export, I get a lot of weight distribution errors. From the multiple master not changing weights until Extra Bold, the OpenType gets extra black around that point as well on the OTF, etc. I have all my weights mapped out properly it seems but I can’t solve the issue. See attached screenshots and thanks for any advice.


I would very strongly recommend using “Axis Location” parameters instead. Add them to all your masters and instances.

Why do you have virtual masters at wght=78 and wght=156? What are those for?

Thank you Sebastian. I do appreciate the reply. I spent some time going through and reading up on axis location. I set up axis location in both masters and exports and the font seems to be working better. I had them set at one point but not on all the instances. Thank you.

The Virtual master was set because I am using two intermediate masters and I read those were needed. I have been exporting both with them and without them and both exports seem to be working well.


Virtual Masters are for something very different, you don’t need to set those if you are just adding intermediates on an existing axis.

Furthermore, you don’t need to set the unicodeRanges parameter manually, Glyphs determines that automatically (it is most probably not just Latin Basic, I assume). Only use it if you know exactly what for.

2 Likes

Thank you Sebastian, this helps so much.