Axis mappings/avar not working in Firefox with a multiaxis VF

If I generate a multiaxis (havent tested with a single axis) variable font in Glyphs 3.0.4 (3100), Firefox (Mac, 95.0b5) seems to ignore Axis Mappings (avar). It works in Chrome, so I dont think it’s the way I set up my file. If convert to designspace/UFO and build with fontmake using the same axis coordinates it works fine, so I don’t think it’s a Firefox bug (or if it is, it’s one that fontmake is accounting for). Has anyone else experienced this?

Can you send me the .glyphs file and the two .ttf files?

ok I sent test files to support@

is there any update? let me know if I can further assist in any way; I am still having this issue in 3108

Consider setting up axis locations for all masters and instances instead.

The Axis Mapping parameter should work. You might need to check it it set up correctly. There was a bug some time ago that would produce a backward setup.

This issues can be circumvented as Rainer (mekkablue) explained.

it does work, in chrome, but not in firefox. the internal and external coordinates displayed in the parameter are correct. the axis locations are already set on both masters and instances :thinking:

If axis locations (the parameters) are set everywhere, then try omitting the axis mappings parameter.

Hmm, that didn’t do it. is the axis location custom parameter for an instance an external coordinate or internal? I have them set to external (e.g. 300, 400, etc) along with the masters. In the axis mappings, I have internal on left column (e.g. “input” on the designspace axis map), external (“output”) on right column. does that all sound right?

As I said. Remove the Axis Mapping parameter. It is not needed.

The Location parameter are always the external values.

Removing the axis mappings parameter has no effect. In Firefox the optical size remains linear, and ignores the axis location custom parameters in the exports

If it works in other apps, it seems to be a bug in Firefox. Could you send me the file that I can have a look?

if it is a bug in Firefox, fontmake does something to compensate for that bug. if I export my setup to designspace/UFO and build with fontmake, there is no issue.

I will put together some files for a test case including the designspace/UFOs so you can take a closer look. thank you, georg

I’m getting this error as well with nearly all my VFs exported from Glyphs. I’ve set up all masters/instances with Axis Locations only.

The error is a bit ambiguous, but I tried ordering my masters/instances in different ways but that didn’t help. Could looking at this code help?

However, if I simply TTX my VF, then TTX the .ttx back to a TFF it fixes the issue. Is fonttools correcting the avar order upon re-compilation?

Could you show the ttx dump of your avar table before recompilation?

Can you send me the .glyphs file?

That error is interesting - I didn’t used to see any errors in Firefox, it would just silently fail. Now I get the same error (Axis value map out of order / Table discarded)

I was just working on axis mappings for an opsz axis yesterday, and the mappings worked fine for me in Chrome and Firefox. Here’s what my Axis Mappings parameter looks like:

Side note: the axis mappings UI has a lot of problems and is difficult to use. I would like to be able to drag the points horizontally instead of just vertically, and the tab and arrow keys do not work in the numeric input fields.

And here’s what my avar table looks like in the exported variable font:

    <segment axis="wght">
    <segment axis="opsz">
      <mapping from="-1.0" to="-1.0"/>
      <mapping from="0.0" to="0.0"/>
      <mapping from="0.25" to="0.6"/>
      <mapping from="0.5" to="0.85"/>
      <mapping from="0.75" to="0.95"/>
      <mapping from="1.0" to="1.0"/>

Justin, do you also have Axis Location parameters defined on your masters and instances, or do you only have Axis Mappings set? I wonder if it’s a mixture of these things that is causing issues

I will take a closer look at the actual avar tables being generated later today to compare binaries between fontmake and Glyphs. Maybe we can better understand this axis order error