Axis Praxis error when the exported variable font is tested

I am testing a variable font exported from Glyphs 3 app. The variable seems to work great but I keep getting the following error on Axis Praxis Website while checking font info. What might be the case? I opened the exported font in Fontlab and there where no axis coordinates. When I added the axis coordinates and exported it through Fontlab and tested it again the error disapeard. Am I doing something wrong seting up the axis in Glyphs? Please Help.


I’m pretty sure it is OK to use name ids below 256 for this purpose.

Or do you disagree @Lorp?

So what seems to be the problem here? Because I can’t resolve the error and I have really tried everything I could possibly think of and the error keeps occurring.

Thanks for this report. I can confirm it is NOT an error and I should fix Axis-Praxis. Here is an extract from the fvar section of the OpenType 1.9 spec:

The subfamilyNameID field provides a name ID that can be used to obtain strings from the ‘name’ table that can be treated as equivalent to name ID 17 (typographic subfamily) strings for the given instance. Values of 2 or 17 can be used; otherwise, values must be greater than 255 and less than 32768. The values 2 or 17 should only be used if the named instance corresponds to the font’s default instance.

The final paragraph of that section is interesting for implementers:

An instance record is not required for the default instance, though an instance record can be provided. When enumerating named instances, the default instance should be enumerated even if there is no corresponding instance record. If an instance record is included for the default instance (that is, an instance record has coordinates set to default values), then the nameID value should be set to either 2 or 17, and the postScriptNameID value should be set to 6.

Thank you so much @mekkablue and @Lorp for your responses. I could not figure out what was wrong and I have also read about name ids while trying to figure out what was the problem. So I suppose there is actually nothing wrong with the exported variable font.

1 Like

Can you please refresh Axis-Praxis and try again? It should now allow nameID 2 or 17 in any instance that is equivalent to the default.

1 Like

I am still getting the same error. I cleared my cache just to be sure and tried from safari as well but the error is still there for some reason…

Please send me the font

@Lorp I have send you the exported file along with the glyphs file in your email. One thing I noticed is that the error disappears if I add another Regular instance with the same axis values but then I end up having two Regular instances. So I don’t know :man_shrugging:. Please have a look and let me know if you can figure out what might be the problem.

Thanks. It’s fixed now, definitely!

Thank you so much. Definitely fixed and no errors one so ever.

1 Like