Background Image disappearing at 390 pt


#1

Hi Team
I’m tracing from a jpeg in the background but as I zoom in beyond 390 pt it disappears.
I am doing something a little abnormal so this might be expected behaviour:

I’m working on one large glyph, 5000 units across, for a lettering composition.
The images is large (about 2000 pixels square) but I’ve also enlarged it by 1000%
I’d still like to zoom on in the details though.

*Update: I just noticed that the image only disappears when I click on a node or handle above 390pt. It reappears when no points are selected as long as it isn’t locked.

All the best
Jamie


#2

Can you send me the .glyphs file and the image?


#3

Done. Thank you!


#5

I hope that I fixed it.


#6

Hi all,

I’m having the same problem with Glyphs 2.5.1 (1141). When I zoom in, at 1500pt the image I’m using disappears. How could I fix it?

Thank you so much.


#7

That happens when you have rotated the image. Thanks for reminding me.


#8

Georg,

I took a look at the image to be sure it was rotated but it wasn’t. Which problem could it be, then?

Thank you again.


#9

Is it still an issue in the latest cutting edge version (Glyphs > Preferences > Updates, enable both checkboxes, click the Update button).


#10

Thanks Rainer. Should I wait to the next cutting edge version? I updated it to 1153 and the problem is still there.


#11

Same issue here, image is visible until 330pt, disappears at 500, comes back at 660, then disappears at 1000 and after. Rotating the image by 0.01deg seems to fix it but really not ideal. Also, strangely, it’s not visible at 1500pt but visible at 1501pt (and a range between 1500 and 2000 as well). Essentially the preset zooms seem to not agree with image visibility.
This is on version 2.5.2 (1150) on newest Macbook Pro (retina), macOS 10.12.6. Image 232 x 278, 300DPI scale 350% x and y.


#12

This is a very strange bug. I can’t fix it but prevent it from happening. So it should not appear now.


#13

Curiously, this is not happening with Glyphs 2.5.2 (1153) on a Macbook Air (non retina) on macOS 10.11.6. Same file, same images. That sounds like one very confusing bug…


#14

I’d not encountered the issue for a while but today I was tracing a sketch and it’s still there. As with you, it disappeared at 500 but then came back at 660.
I rotated it 001° which seems to have fixed it. Very Strange.
I’m on Version 2.5.1 (1141)


#15

Please try with the latest beta.


#16

This is a very strange behavior of the system. I didn’t figure it out yet. I think I calculate everything correctly but the system simply doesn’t draw it.