Background image not visible in editing mode

I’ve inserted an image in the Background, but when I change to editing, the image is not visible.

I’ve tried both Show image and Show background but nothing works. Am I missing something?

Glyphs 2.4

I assume you want a scan or some other kind of pixel image behind your paths, right? There is a difference between Image and Background. Background is intended as a backup of the whole foreground layer; what you probably did is insert your image into the background layer. If that is the case, it will only be visible if you switch to the background and turn on images. What you probably want is the Image of the foreground.


  1. Make sure you are in the foreground (cmd-B toggles between fore- and background).
  2. Drag your image into the active layer of the glyph.
  3. Make sure you turn on View > Show Image before you start drawing.

Your assumption is right :slight_smile: The thing is:

  1. I would like the image to be dimmed
  2. That I can easily toggle the image “layer” on and off
  3. That I don’t select the image by mistake when selecting anchor points

That’s why I thought placing it in the Background would be the logical thing to do. Can I achieve 1-3 in another way?


You can set a keyboard shortcut for Show Image in System Preferences > Keyboard > Shortcuts > App Shortcuts.

You can lock it. Right-click the image, and choose Lock from the context menu.

Best shot: Right click, Reveal in Finder and edit the image.

You could use an Automator Service for dimming. Try Photos > Apply Quartz Composition > Gamma Adjust, or some of the other color filters. Save it, and you have it in the Finder context menu.

The image has a alpha property. it is not available in the UI but you can write a one line script to change it. Put the following in the Macro window or in a script.

Layer.backgroundImage.alpha = 10 # in %
1 Like

Thanks a lot. Work fine this way :slight_smile: