Background layer data disappeared after update from Version 2.4.1 (983) to 2.5.1

I just added Glyphs to my font design apps (mostly Robofont before).
I was using the trial version and about to purchase a license… I had worked on 2.4.1 for a couple of week and updated to 2.5.1 last night. When I started the updated app, all information (saved/copied back ups of layers and all paths/components) in the Background layer have disappeared. I reinstalled the 2.4.1 version but the data is still not there (anymore). Background is selected in ‘View’. Any advice on how to get the data back?
Thanks, Nico

That is strange. Do you have any backup? I would need to have a look at the files. And can you send me one of “damaged” files, too?

Thanks for the files.

You saved the files as .ufo. In version 2.5, I needed to remove the capability to store background and extra layers. It was stored in the format that RoboFont is using and the Author of that tool forbid me to use that data. So open the file in 2.4.1, save it as a .glyphs file and open this in 2.5.

While working on the font, it is recommended to always save as .glyphs files and only to convert to .ufo if needed.

Maybe the UFO export warning should add a note about layer backgrounds. I will add it to the UFO tutorial.

Thanks for the information.
That makes complete sense, but it didn’t seem to work with the file I sent, unfortunately.
You are seeing the background data when you open the files?