Bracket trick in variable font not working

I can’t get the bracket trick to work on a variable font I’m working on.
I have Weight(20–200) and Width(0–900) axis with 4 masters.
The preview area shows it correctly and so does the Variable Font Prievew plugin.
However, when I test it in Axis Praxis and Illustrator only the bracketed layers are used.

I would also like the bar to break sooner in the condensed styles than the wide styles. But that doesn’t seem possable right now. I tried adding the width axis like “Wide Black [90, 400]” but that doesn’t produce the correct result.

What’s the best way to go about this?

MacOS 10.11.6
Glyphs Version 2.6.1 (1195)

I think something changed with bracket layers in the most recent Glyphs update.
I tested an older varable font of mine that uses bracket layers and it worked as expected.
I re-exported it in the current Glyphs version without changing anything and the glyph swapping stopped working.

What previous version does work for you?

It would have been 2.5 but I’m not sure what build. It was a font I designed last year that the bracket trick worked in the exported variable font.

There was a bug that would create wrong values under certain circumstances, maybe it is not completely fixed yet. Can you send me the file please? Just with the Cent symbol, that suffices.

I downloaded the latest build (1199) and it seems to be working again. Thanks!
I’ll go ahead and send you the file as I have a related question.

1 Like

It’s still not working for me (I have 1199). Or rather, it’s working for one glyph but not for another (!)

Which setup do they have? Can you send me the two glyphs?

I suppose you mean a glyphs file with just the relevant glyphs? I’ve sent you a link to it. It’s working for cent but not for dollar.onum. (and there’s this odd up-and-down shift happening with cent.) These were working in an earlier version of Glyphs–but sorry, I don’t know which.