Bracket trick not working in components

For example, /Oslash is constructed from /O component and a slash (path). Bracket trick has been done for all masters and works nicely in Glyphs and when exported (testing in Indesign and Drawbot).

/Oslashacute is constructed from /Oslash and /acute components. Bracket trick has also been done for all masters, with same settings as in /Oslash. It works in Glyphs, but not when exported. Instead, it shows just straight interpolation between masters, ignoring the bracket trick.

Decomposing /Oslashacute before exporting fixes the problem, but is cumbersome and I’d rather avoid that.

Are there any other methods to solve this?

In the latest version of Glyphs, you shouldn’t need the bracket layers in Oslashacute.

Thanks Georg. I exported the font in Glyphs 3 and indeed that fixed the issue, almost. All glyphs except /oslash and /oslashacute work in the exported file. Which is weird because /oslash bracket trick worked fine when I exported it from Glyphs 2.

Do you have a reverse bracket layer?

Hint:

Better: from O component and slashlongcomb.case component.

Ok, now everything exports nicely.

A note about weird naming issue:

  • Glyphs 2 exported the font name as it should be
  • imported to Glyphs 3, the same file exported (VF) with “regular” added to the family name
  • I added “variable font family name and style name” custom params and exported that version (didn’t help the naming)
  • Took the above custom params away. After that, exported VF font with font name as it should be, without the “regular” addition.

@mekkablue Ok, thanks. But care to elaborate why including both O and slash as components is better?

Oh, one more thing: bracket layers that were imported from G2 got renamed to [260‹wg] and open up a handy dialog (see screenshot) when edited. If I duplicate a layer and rename it (as in your tutorial), it will not create a similar dialog version of the bracket layer. How to do it manually?

The tutorial is not up to date. Renaming doesn’t do anything any more.

Ok. My question is: how do I get that nice dialog in the screenshot, seen in below the light layer?

Right click the layer and select ‘Alternate’.

Gotcha, thanks!

Yes it is:

The two old Glyphs 2 tutorials have a version note at the top.

1 Like

@mekkablue I tried to do what you suggested, constructing /Oslash from /O and /slashlongcomb.case components – bracket trick works in exported /Oslash but not in /Oslashacute (contains /Oslash and /acutecomb components). I tried this with and without bracket layers in /Oslashacute.

The same font, with the same layer setup, but /Oslash constructed from /O component and a path – bracket trick works in exported, both /Oslashacute and /Oslash.