Bracket trick preview

Now I followed this tutorial step by step and it’s work correct but in preview don’t work well and I try to reverse bracket trick but this step makes the master not Compatible and I lost the point or the weight of the bracket trick

What exactly is the problem? Instances missing in preview?

as you see in the first screenshot the dollar sign in preview at the bold master showing as the wrong one.
I think it should be the one with two short vertical stems (bars) in preview bolder one in the second screenshot, not the original one (with one long stem in middle) like the first screenshot.

The font view shows the master layer. What you can do is to use a revers bracket layer. Use the ‘bold [200]’ as master and rename the former master to ‘]200]’.

35%20PM


please check first the original post, now I tried the tutorial and reverse bracket,
In the first case interpolates correctly, but you always see the wrong bold dollar sign in me Font view
and now in this case, as shown in the screenshot interpolates NOT correctly, but you always see the right bold dollar sign in me Font view, the problem how it’s look in font view and typing view in the first case.

Now I get it, thanks for clarifying. Will take a look. In the meantime: can you please send me the .glyphs file to support (at) (this website without www), that may help.

I see what the problem was. The bracket trick works a little differently. [200] means use this master after 200. In other words, it will be used starting at 200.000001.

But ]200] means use this master until 200. In other words it will be used exactly until 200.

Now in your setup, you had an instance at exactly 200. That meant that Glyphs was trying to interpolate between 2 incompatible masters in that very point of the interpolation.

Workaround: Change the number value of the reverse bracket layer (or both layers, if you prefer that), to 201.

I will update the tutorial to make this clearer. Thank you for sending me the file.

2 Likes

Thank you for supporting now it’s working clear. :smiley:

Hai, I have the same problem too. I have following this instruction, it’s work correct in the master but in preview doesn’t work well, it still shows the wrong layer.

56

I think that it works as intended. In this case you should use a regular [] bracket layer (instead of the reverse bracket). Switch the masters (the one with the thin horizontal is the master and the “thick” is the bracket layer).

Or and that might be the better option here: use a brace layer.

I can’t use the brace layer because every time I tried to re-interpolate is always force quit.

What version do you have?

2.6.5 (1320)

Try the latest beta please. Go to Glyphs > Preferences > Updates, activate both checkboxes and press the Update button.