Bug - Can't Edit Unicode Character Field

The latest build 1.4.3 (584) removed the ability to edit Unicode value for character. I am using “Private” character space to use icons as characters. Without being able to assign custom character names in private space I can no longer add new icons.

Is this something that can be fixed soon?

Really appreciate any feedback on this issue!

Never mind, I’ve figured it out. It is not a bug, but a “feature”. To solve this, go to File > Font Info > Other Settings, then toggle ON “Don’t use nice names”. This will enable the field to be editable.

This is not necessary for glyphs with PUA Unicode values. Here’s how:

  1. Create the glyph with a name that follows the /uniXXXX scheme (or /uXXXXX for five-digit Unicode values), e.g. uniE000
  2. Rename the glyph to a custom name that is not already in use for something else. The glyph will keep the Unicode value.