Bug: Find Glyph results after backspacing

Using 2.3.1 (899), if I do Cmd-F to find a glyph and type a letter, I see the matches at the top of the results are the glyphs names that start with that letter.

That works well, but I notice that if I type a letter then backspace to delete it and type a new one (or the same one), I no longer get those well ordered results.

The workaround is that if you backspace twice, you can get back to the good results.

I can’t reproduce this. But maybe its just to late today.

A more detailed report:
Open a Glyphs file with many glyphs.
Open an editing tab.
Type a C. Result: results start with C, Cacute, Ccaron, Ccedilla, etc.
Backspace to delete the C.
Type C again. Result: results start with Aacute, Acircumflex, Amacron, C.

I assume the second time it’s giving matches for “includes C” rather than “begins with C,” and is providing them in glyph index order.

@eliason I’m experiencing the same thing. G2.3.1 [899] OS X 10.11.5.

The behaviour is different on 10.10 and 10.11. I was testing on 10.10 and it worked fine but not so on 10.11. I fixed it.