Bug in Transformation filter as custom parameter?

This is an excerpt from the handbook (some symbols are lost due to formatting, but anyway):

The Value code for the custom parameter contains
a range of optional arguments: Transformations; LSB:<±*/shift>; RSB:<±*/shift>; Width:<±shift>; ScaleX:; ScaleY:; Slant:; SlantCorrection:; OffsetX:; OffsetY:; Origin: . The arguments optionally take the indicated prefixes for relative operations, or will set it to the specified value if no operators are supplied.

I didn’t know how I was supposed to fill the <±*/shift> part and I tried to copy the custom parameter value. And I noticed that no matter if “Relative” option is set or not, the copied value is exactly the same. What is the intended format of absolute value and relative? Is the “Copy” menu functioning as intended?

While I’m at it, I give other feedbacks on it:
– “Background” tab of Transformation filter does not actually offer you custom parameter option although it could theoretically be possible. If it does not support custom parameter, I think the cog icon should disappear in order to avoid confusion.
– I wonder why filter custom parameters have different naming schemes; in other words, why filter naming is inconsistent; HatchOutlineFilter, GlyphsFilterOffsetCurve, Roughenizer, GlyphsFilterRoundCorner, RoundedFont, and so on. Isn’t it better to make GlyphsFilter be the prefix of all filters or simply drop it everywhere, as it’s obvious that it’s a filter (because the property says so)?
– Why do I have to use the percent value as fraction in stroke position (OffsetCurve) but as it is in scaling factor (Transform)?

Possibly a bug in the gear menu. LSB:+20 does work for relative change, though, LSB:20 would be the absolute change.

I think you can already use RoundCorner and OffsetCurve. IOW, you should be able to leave out the GlyphsFilter part.

The problem is, now that it is introduced and has been used as such, how do you keep backwards compatibility and make it consistent at the same time? Making it consistent will break the export of existing files.

I think the intention is clear depending on the number. If stroke position is 50 as opposed to 0.5, it’s clearly half. Besides, stroke position does not accept a value less than 1. When the intended value is 200%, that is 2.0, but I think it’s still safe to assume the user means 200%. And 200% sounds already crazy number to try (I think almost everyone use 0—100%).

And how can I make a distinction between absolute -20 and subtract by 20?

How about this idea?: only if you specify the number with two fractional digits (e.g. 0.80), it’ll be interpreted as 80%

I added that you can force absolute values by adding an equal sign (RSB:=-20).

Edit: I just found that the RSB:=-20 syntax was already supported but was broken for the preview. It should work on export.

Is it possible to run Hatch Outline filter as a Custom Parameter over an Instance?
I copied the gear values and pasted it in a Filter custom Parameter, did not work though !

Would be easier to have Properties of Custom parameters Alphabetically listed.

Works for me. Two potential pitfalls:

  1. You must make sure that your Offset Path value is larger than zero. Otherwise you have no closed paths.
  2. Click and paste directly in the Custom Parameter table; you do not need to create a Filter parameter first.

You can do that by clicking on the Property column title.

The order of filters, though, should not be alphabetical, but chronological.

It works in Instant Preview; but Export is unable to handle it !
I tested with different filter values less condensed hatch lines and also tried with Decompose Custom parameter before;
The Export “Processing Wheel” does not end;
Working on OS High Sierra 10.13.12 MacBook Pro 2.9 GHz Intel Core i7 , 2017

Can you send me an sample file?

Thnx Georg;
I sent a sample file

You need to add a Disable Subroutines parameter to the font. Otherwise makeOTF takes ages to add those. Or export as TrueType.

1 Like

Terrific @#Georg it was solved;
However there is one more relevant Issue discussed with @mekkablue ;
I’d appreciate your reply via email.

Thanks again;
The Plugin manager does not display Hatch Outline filter;
I tried to uninstall and to download the fixed version you mentioned;
It is not there !!
I searched also on GitHub … cannot find how to update it

The fixed version will come with an update of the app.