Bug report: Rectangle tool produces imperfect squares with both Shift & Option

I’m reporting this here because of the problem with bugreport.glyphsapp.com.

The title pretty much says it all: Rectangle tool produces imperfect squares (with |Δx-Δy|=1) when used with both Shift & Option.

Probably a grid rounding problem. Couldn’t reliably reproduce it yet, but could see the phenomenon approx 10-20% of times I tried.

Did you see a difference in frequency under certain circumstances? I had the feeling it happened more often when I pulled to the left, but that may be a coincidence.

I’ve just played with it a bit more. The zoom seems to play a major role here. As I zoom in, it becomes almost impossible to reproduce it. But if I zoom out enough, then as I drag the cursor the shape goes through imperfect squares, and I can just stop at one of them. Even if I’ve stopped at a perfect square, I can easily turn it into an imperfect one; all it takes is to move the cursor a tiny bit up or down. So basically I can always reproduce it

I fixed it.

1 Like

Thanks :slightly_smiling_face: