Bug: rotating global guides

In 1.3.19 (487), If I create a guide and then convert it to global, then when I rotate it the screen doesn’t update to show it move as I drag it. When I release the mouse button the guide jumps to the new angle–so in other words, the guide is actually rotating, but it can’t be seen moving during the rotation.

Version 1.3.19 (487)

I tested it with old global guides and also by making new ones.

On my system the guides move and update while moving, as expected.

In case it helps, here’s an older thread about an apparently related bug that was fixed:

I haven’t seen this bug. But I will say that I run into all kinds of weird bugs with guides, and especially global guides, when using 1.3.19 betas. I haven’t filed bug reports for them because the problems occur inconsistently so I can’t intentionally reproduce them. Restarting Glyphs often clears up the problem Among problems I have seen in 1.3.19:
• Working with guides breaks undo, so that only changes to guides, not outlines, can be undone.
• Undo does not work with guides/does not work with local guides/does not work with global guides
• Selecting guides does not cause the info box to appear.
• When a guide is moved the new position information does not appear in the info box.
• Global guides can be selected by clicking on any part of the guide instead of the control point
• Global guide behavior is totally erratic in the background layer and anything that can go wrong does

This should only happen with global guides. I fixed that. As the undo is glyph based and the global guides do not belong to a glyph there is no undo manager to work with. This is strange. Do you see anything in the console about this? Fixed it. This is a feature. I made sure that you can’t click and drag it accidentally. The other improvements might help here a bit, too.

This still happens in 1.3.20.