Build 1185 crashes with hand tool

bug

#1

I yesterday updated to version 1185, but it seems to crash the moment I use the (space bar) hand tool. Using the hand tool from the toolbar gives the same result. Normal space bar use (preview glyph) works fine.

Message is:
*** Terminating app due to uncaught exception ‘NSInvalidArgumentException’, reason: ‘-[NSView documentVisibleRect]: unrecognized selector sent to instance 0x60000253d920’

I can drop the larger details if you want. Is this something on my end?


#2

Me too, same problem.


#3

Same here.


#4

Tried disabling all plug-ins?


#5

Got the same problem, plus the remains the same regardless of wich tool i’m using.


#6

Yes, tried. Disable all plugins but crashed again.


#7

Sorry fro that. I’ll fix it.

Edit: fixed it.


#8

I reinstalled 1184, because 1185 didn’t work well.

Info window half sunk in lower bar. Mouse Icons didn’t change according to function (no pen tool when selected for example). Etc.

MacOs High Sierra, MB Pro


#9

Please try version 1186.


#10

Thanks Georg!

Though now, the right mouse command (control + click) doesn’t seem to work anymore?
I am running Mogave…


#11

I do have some problems with using my keyboard. Copy, Select, moving points with the arrow keys doesn’t seem to work properly. Sometimes it works, sometimes not…

Using 1186 on Mojave


#12

1186: Some keys become unresponsive after you have typed in a number input. Switching tabs (and back again) is a temporary workaround.


#13

That is fixed in 1187.


#14

Cheers for the update! It all works perfectly now.