C2SC and LOCL interaction problem

I have an aacute.loclHUN that makes the acute shallower so as to harmonize more with the cap-acute and Hungarian double-acutes and thus present a more homogeneous image in Hungarian language. This was suggested by a user on typografie.info. The same user also suggested offering a stylistic alternates in which all of these accents were harmonized with the original steep acutes instead. Thus, I have an Aacute.loclHUN.ss13 with a steeper acute accent than the regular Aacute.

The problem now is that Aacute.loclHUN.ss13 is now resistant to C2SC. Aacute remains capital-sized when I activate loclHUN, S2SC, and SS13. The glyphs aacute.loclHUN.sc and aacute.loclHUN.sc.ss13 do exist and look as they should. These features do appear in the features list in the aforementioned order. What’s going wrong? Is there something going wrong in how S2SC chooses replacement glyphs?

Are the suffixes in the order of the features in Font Info?


If the c2cs and smcp features are before the ssXX features it should work. If you can’t fix it, send us the file.

The order of features is correct. Here is the file:


That problem is still unsolved, by the way. :frowning2:

Sorry that it took so long. I fixed it.

Thanks! :smiley:

Sorry about this, but in 885 it still doesn’t work for me. This is the string /Aacute/A/aacute.loclHUN.sc set with loclHUN and c2sc activated:

I have regenerated and compiled c2sc and smcp several times.

I suppose it is fixed in the upcoming version. A little patience please.

OK, no problem then. :wink:

When are you planning to release that version? I have to hand over my final release of Cormorant tomorrow, and I was hoping to fix this issue before it freezes…

The update is online.

Awesome, thanks!

Something’s still wrong. I have a Macedonian /be-cy.loclMKD in my font, and it does produce an entry in the locl feature, but not in the Languagesystems feature. I cannot select Macedonian in the Feature menu in an Edit window in Glyphs. I’m also told that using loclMKD and c2sc with my exported TTF font will basically disable c2sc entirely.



I fixed the missing Macedonian languagesystem statement.

Awesome! Is there going to be a Glyphs update until I have to hand in Cormorant tomorrow…? Or would it do for now if I added «languagesystem cyrl MKD;» in there by hand?

You can add that line in an extra prefix.

What’s an extra prefix?

Can I just switch the languagesystems feature to manual and add that line below the others?

EDIT: Just wrote it into the languagesystems prefix; worked.

Extra prefix: click on the plus button, choose Prefix, give it a name like MKD, move it after the Languagesystems prefix, add the Macedonian line.

This way, you can leave the original Languagesystems automated.