Can I use ‘Normal’ instead of ‘Regular’?

Can I use ‘Normal’ instead of ‘Regular’ in the style naming?

This is rather vague. Do you mean for instances? Bear in mind that Regular is generally considered the elidable style name particle, so it’s a safer bet to use Regular for things to work automatically.

Yes, some of the automagic features are not working as expected, nor Rainer’s Instance Cooker script.

I was just wondering if Glyphs would have built-in logic to see that ‘normal’ is used rather than ‘regular’.

There are a lot places that assume ‘Regular’, in Glyphs and in Apps that use the font.
E.g. you might get an automatic ‘Regular’ style next to your ‘Normal’ in some apps.

This should be possible.

Alright. I thought differently for some reason. I tried ‘regular’ in Rainer’s Instance Cooker, and it solved some problems, but the style-linking of all the Italics is still not set.

It does work for me as expected with ‘Normal’. What is your recipe?

Am I misremembering that the style linking is done by your script? When I run this

100>100:UltraThin Italic
145>200:Thin Italic
200>300:Light Italic
350>500:Medium Italic
450>600:SemiBold Italic
570>700:Bold Italic
720>800:ExtraBold Italic
900>900:Black Italic


I don’t get any linking.

Two things.

  1. Don’t mark italic as elidable. It is not. Only the words Regular or perhaps in your case Normal. Elidable means that the particle disappears when it is combined with another particle. E.g. Regular (weight) + Italic (slope) = Italic.

  2. And in this case, you don’t need an axis Italic. The point of instance cooker is that you’re constructing many instances by multiplying the particles for each axis. If you have only one axis, the script won’t make much sense.

I can tell you that you do need the Italic axis set to 1 in the Italic file. If you remove it, the Italic axis is set to 0 which is wrong (possibly only wrong in a variable font which this is). When not set, none of the style linking is set.

If I run the cooker with the Italic axis set to 1, then all the italic styles are correctly linked to the uprights, but the ‘Italic’ is named ‘Italic Italic’.

The reason I use the script for only one axis is because there are more romans and italics than two, and they need to be kept in sync with each other and a spreadsheet, thus using the cooker was a way to go about that.

In Glyphs 3.2, name your Variable Font Setting Italic and it will set ital=1. If you’re not interpolating along the ital axis, best to remove it.

The style linking bits only apply to static instances. For setting those, run the Set Style Linking script. It will probably assume “Regular” as the name of the regular elidable style, so you may need to manually correct the style linking for Italic, Bold, and Bold Italic.

In Glyphs 3.2, name your Variable Font Setting Italic and it will set ital=1. If you’re not interpolating along the ital axis, best to remove it.

The Variable Font Setting Name is set to Italic, but that does not automatically set the Axes Coordinates > Italic to 1.

If I run the following:


Then the Axes Coordinates > Italic is set to 0, and the instances are borked and not linked.

Anyhoot, we’ve probably both have better things to do than this.

Can you send me the font file? Because it works for me.