“Can’t convert to compatible TrueType curves” with exactly same shapes

I don’t know why this keep red flagging. The glyph was fine and then out of the blue started red flagging. I even tried to literally copy the same glyph and anchors at the other instance but the error keeps on. Maybe some curve is wrongly drawn. I don’t know. Could you guys help me? I saw previous forums but the thing is I’m not even with different shapes. I’m attaching some images to see the issue.

Plus there’re some glyphs that often flag it and then (with not even touching them) they correct themselves.

That’s the shape I actually want. The error appeared in uppercase R, which I didn’t change anything, but suddenly disappears too.

Can you send me the file?

Sure. How do I do that?

send and email to support at this domain.


Can you update to the latest cutting edge version (activate it in Preference > Updates).


And do you see the problem now?

Yes :pensive:
edit: if the problem is still or if I can see what to fix?

You should be able to see the problem now. Have a good look at the light master.

It showed me lots of leftover corner points in the light (previous inktraps). I deleted them all but it’s still red. I also aligned the yellow curves and now everything is green (but the glyph is yellow)

There are some more corners that where still not shown (I fixed that).
Please run this script in the Macro Window to fix this:

for l in Layer.parent.layers:
    l.hints = None