Can’t save on an external AFP volume

Hi guys!

I just started using Glyphs on my new machine at home (mirrored the installation from my office machine) and wanted to save a font from out of Glyphs onto my server volume (AFP), but it doesn’t work … see attached screenshot. It’s in german, but it says that the file couldn’t be saved because it doesn’t exist. Which can’t be, because I just edited it :slight_smile:

I’m on OS x 10.14.6 and the latest Glyphs Version 2.6.4 (1286).

Thanks in advance for any help!

Ah, forgot to mention: Saving locally on the Mac’s internal volume works as intended, but I can’t push every file I work on back and forth all the time.

Likely a Path issue. Save the file to your Desktop, then close the file. Then open the file on the Desktop and do a Save As to the external; see if that works. If it does that will confirm it is a Path issue.

1 Like

This issue does not occur in other apps? Try the latest beta perhaps. Go to Glyphs > Preferences > Updates, activate both checkboxes and press the Update button.

Thanks for your answers!

@George_Thomas I tried this route before. Still, it doesn’t save it to external.

@mekkablue AI and PS save on the volume as intended. Just tried the beta – same problem. It also appears on other files and in other folders of the volume, so no luck here :frowning_face:

  • Can you try with other Mac-native apps, like TextEdit?
  • Consider disabling Glyphs > Preferences > User Settings > Use Versions

What kind of server is that? I might need to recreate the setup to debug this.

@mekkablue Oh wow, that seemed to be the right hint … TextEdit won’t save there as well. What to do then?
@GeorgSeifert it’s a Synology server running AFP service, connected via LAN. No fancy settings or so though :confused:

Can you try to connect via Samba?

Yes, tried it via Samba, and also no luck here … same error message, no saving. :frowning:

Any funny characters in the path name?

Not even a blank space …

As this also effects Apples apps, you might need to ask on the Synology forum.

Thanks for your help, @GeorgSeifert, George_Thomas and @mekkablue!
I’ll check the issue with the Synology forums.