Cannot enable spaces between glyphs

I’m really hoping someone can help me with an issue I’m having because I’ve pretty much exhausted my options and spent days fighting with it. I’ve designed this font for a fantasy language and everything is fine when I import it into my Fonts Book - every symbol corresponds with the correct letters and numbers, only when I attempt to use it I’m unable to include spaces.

I’ve attempted to Google this issue, but the only results I find are people trying to get rid of their spaces. I’ve tried everything I can think of which has ended in 70 separate saves and a whole lot of used patience. Apparently I need “space 0020” - but the documents has that. I figured maybe the variables were wrong, so I downloaded another font online and copied and pasted that font’s space and compared the variables between the two but nope, nothing seems to work.

I’m really new to Glyphs - obviously, this is probably a very simple problem with an even easier solution but any help with this would be really appreciated because at this point my spiteful little heart is determined to get the blasted thing to work just for schadenfreude of showing this font that it will contain spaces!

(P.S. I know none of the terminology for this, I’m really sorry. I do digital art and tend to stick to the front end of things.)

This is probably a font cache problem. Read this please:

Thank you so much!! It works now. You have know idea how crazy this has been driving me. I really, really appreciated your help!