Can't export font

I have been updating the kerning in an old font design of mine for a few days now and when I go to export it to OTF each weight is exported except for the “Display” weight with the drop shadow. I know it’s a pretty complex font but I’m baffled at how to get this to successfully export. I have even created a version where I decomposed all the components and tidied up the paths and it still just spins endlessly.

Below is a link to the file for you to try out.

Thank you in advance for your help!

Add a “Disable Subroutines” custom parameter to the shadow layer. The font is exporting fine, but it takes an hour or more. The subroutinisation is a very complex operation with hatched paths like yours.

1 Like

Worked like a charm! Thanks Georg!

For anyone who is having the same problem. Make sure to add the “Disable Subroutines” parameter on the Instance. I originally added it to the master and it didn’t work. Once I added the customer parameter to the Instance it worked perfectly.