Can't export Variable Font

I can’t export a Variable Font, even if there is only one (n) glyph included in the font. What’s the problem with that?

The problem is usually inflecting curves that are hard to transpose from PS to TT curves. Can you post a screenshot of your n?

And perhaps see if it works better in the latest beta. Go to Glyphs > Preferences > Updates, activate both checkboxes and press the Update button.

I tried it with the update to the version 2.6.2 (1264) but the issue is still the same.

I suspect it has to do with the point arrangement in the other masters, most likely the bold. That somewhere there is a small inflection and in the others not.

Hmm, I will try but if I export the whole font there is a report for „Acircumflex“, where is only one form on the regular master yet. If I delete the Acircumflex there is a report for another glyph. :thinking:

It always reports the first glyph in which it encounters such a problem. Perhaps try downgrading to see if the problem did not occur at one point?

Or can you please send the .glyphs file to support (at) (this website without www). We will have a look.

You might need to add a “Enforce Compatibility Check” custom parameter to the font. That way it will mark the incompatible glyphs in the font view.

I am looking forward to try this. But could you explain me exactly how this is to do? Thank you in advance.

The parameter is explained in the Variable Fonts tutorial.

Thanks for the hint. I have tested the export with the function “Enforce Compatibility Check”, unfortunately without success. I send you the font file now by mail.

The parameter is not effecting the export directly. It will mark glyphs as not compatible in font view.

Ok, I can see the red marks on many of the glyphs. But what is the mistake in detail? I hope you can take a look to the file I sent this morning (Support).

I had a look at the file, and it is very simple: the first and third masters are (mostly) empty. You cannot interpolate between nothing and something.

Please read the Multiple Masters tutorials to understand the concept of compatibility. In short, all masters must contain the same number and order of points, components and anchors for interpolation to work. For more details, please refer to the tutorial and the chapters in the handbook.

But why can I delete all the glyphs except the „n“ (with a form on every master) and the error is still the same? :thinking:

The n is not compatible.

Please read this tutorial:

It explains compatibility, how to check for it, and how to make it compatible when it is not.

Thanks for the link. I will try to find out why the outlines are not compatible.