Can't get my font to be work in Microsoft Word


#1

Hello everyone,

For an unknown reason, since I bought the app I created two fonts and none of them appear in Microsoft Word. Both of them work fine with Adobe Photoshop and Illustrator, so I’m a bit confused. Also, this is a problem that I didn’t have with the trial version of Glyphs…
I have tried both .ttf and .otf, and it doesn’t change anything.
Can someone please help me out?

Kind regards

Nicolas


#2

How did you install the fonts?


#3

Right click -> font book -> install font

I also tried to drag the font installed to the ‘Microsoft Office Compatibility’ category


#4

Are you aware of font cache problems? Read this: http://www.glyphsapp.com/tutorials/eliminating-font-cache-problems

Plus, specific Mac Office caches: http://support.microsoft.com/kb/313535/EN-US

If that does not help, please send the .glyphs file to support at this domain.


#5

Yes, I became aware of it before I decided to create this topic… I also tried using a third-party utility to clear cache (font doctor), and even though it did clean what needed to be cleaned it still hasn’t had the effect I was hoping for.

I don’t know if it makes any difference, but I have just realized that about 10 fonts I recently installed doesn’t work in Microsoft Word either


#6

Which version of Word?
Font Doctor may be outdated. Please try the methods described in the tutorial and on the Microsoft help page.


#7

I use the 2011, but I also have reinstalled the 2008 to see if it made any difference.

I have tried the first method and it didn’t do anything. I haven’t been able to complete the other one though, but the “office font cache” folder doesn’t exist. I have read a lot of articles since yesterday, and according to what I read there is only one way to clear cache in Microsoft Word, but since the folder doesn’t exist I am stuck.
I have also tried Font Finagler, but all it does is reset the font book when I move caches to the trash.
I realized that it is definitely a problem with Word, because I installed Open Office and just like with Illustrator and Photoshop it works fine


#8

Did you try in a different user, a different machine?
And can you send us the .glyphs file?


#9

Yes I did.
Sure, I am going to send it right away. Thank you for your help


#10

It works for me so you probably have a cache problem.

But a font in this early stage should not be tested in Office. There are to many problems. The only practical way to test fonts while designing them is in Adobe Indesign.


#11

Hi, i have found this porblem too with exports from glyphs mini not appearing in Word.

The appear in adobe programs, but not in word.
I have gone through the steps to clear the font cache and no change.

it most likely a user error, but would love some help.


#12

Try with another font name (I usually add a incrementing number to the font name).
Install the font with FontBook.
Restart Word.


#13

Microsoft apps have their own additional font caches. See in the help files of the version of Word you are using how to clean the caches.


#14

The cache problem can be avoided by changing the font name.
And how did you install the font?


#15

Hello,

I have the same the problem with one of my fonts. I already clean the cache of my computer, nevertheless, when I used the font in Word doesn’t work properly. Kerning tends to break up and weights looks deformed.
I installed the font trough fontexplorer. There is another solution apart clean the cache?

Warm regards.


#16

Don’t. Read this please:
http://www.glyphsapp.com/tutorials/eliminating-font-cache-problems


#17

Hello everyone,

I have a problem with Word too but i think isn’t the same… The spacing between the letters isn’t good and the ligatures doesn’t exist… But in Ai, Ps and In no problems !

Can you help me please ? Sorry for my bad english !
Kind regards.


#18

Unlikely that it is spacing. Word has kerning off by default. Quick user fix is to turn on kerning in Word, but what you should really do is fix your pacing so that the font works acceptably without kerning.


#19

Thanks @mekkablue ! Yes the problem is the kerning but unfortunately my typeface is an english script so it is really difficult to do without kerning. I gonna check out how to activate the kerning on Word and I shall keep my fingers crossed !!

Thank you !


#20

You could try and repeat the kern lookups in dist. dist is a feature that is always on in Word.

Look inside the .fea file in the Temp folder to see which kern lookups you have, then create a new dist feature in Font Info > Features, and add these lines to its code:

lookup kern_DFLT;
lookup kern_latn; 

I cannot test it in Word myself now. Please try and report back.