Can't Open Glyphs 3 on Big Sur

Hi - I’ve been on the trial version of Glyphs 3 for a week now and I really like it - I’ve taken the class of Charles Nix and have been tinkering with the filters but now, it won’t open at all. I’ve done the troubleshooting steps -removed the plugin folder, also tried removing the glyphs3 application support folder and the software would crash immediately after clicking either Reopen file or Don’t re-open.

The shift+Option also doesn’t work for me- I’ve checked the keyboard input in the settings as well.

I just downloaded the trial software again and it still won’t open… Anything else I should try?

Does it work in a different user? Set up a new user in system preferences, login, and start Glyphs from there.

The most likely cause is an issue with a plug-in. Hold down Option+Shift (double check you’re really holding down these two; not Cmd or Ctrl) during app start to disable plug-ins. If Glyphs starts, then it is a matter of finding out which plug-in causes the trouble. Please report back here if you know which one it was.

Then look in the crash logs in

See this tutorial for more measures you can take.

thanks for the response … Ok, it opens if I log in as a guest user on my machine -

So I tried again in my my account --I don’t know how it can be the plugin because I’ve done the manual removing of plugins (removed to another plugin off folder) and the removing of the preferences folder as well. The Shift+Option doesn’t work for me - I’ve double checked the keyboard settings as well. Is there anyway I can disable the last font file I was tinkering with because I feel like I was trying out so many things and it keeps on popping up right before it crashes again, it must be in that file…

this is what the crash log says - same message on all: Tue Jun 8 18:29:58 2021
*** -[__NSArrayM objectAtIndexedSubscript:]: index 10 beyond bounds [0 … 9]

I finally got it to work - I didn’t see the instructions of the deleting the autosave file. That made it open again - thank you!

You don’t happen to have that broken autosave file around?

I can check if its still there- let me know where to send it-

1 Like

If you find it, please send the .glyphs file to support (at) (this website without ‘www’ or ‘forum’).

Thanks in advance!