Can't run any filter in Glyphs 3

Hi Glyphs Forum! I’ve been trying to run Mekkablue’s filters and other ones but glyphs just doesn’t seem to respond, both from the help menu and from the filters one. Any solution?
I’m running v 3.0.1 on Big Sur

Did you install them through Window > Plugin Manager? That is necessary for passing the macOS security check.

1 Like

Yes I did, and I’ve tried with several script packages, but it won’t work :sweat_smile:

Python and vanilla are installed?
And which Python is selected in Preferences > Addons?

Ok so I installed all the modules and it worked for a bit but then it crashed few minutes later and at the reopening I’m facing the same problem as before. :expressionless:
My python version is 3.8.5

Make sure you send the crash reports as described in the Crashes tutorial.

Scripts: please report the error you get in Window > Macro Panel.

1 Like

The problem is:
ModuleNotFoundError: No module named ‘Foundation’

Try this:

  1. Window > Plugin Manager > Modules: uninstall and reinstall Python
  2. Glyphs > Preferences > Addons: pick the Python that says ‘(Glyphs)’ behind the version number.
  3. Restart the app.
1 Like

Worked! thank you very much :slight_smile:

1 Like