Can't start any version of Glyphs after updating to 3135

I started up Glyphs 3.1.1 (3134) this afternoon and got a notification of a new cutting edge update (3135). As usual, I did the update. The new version crashed on launch. Even the Glyphs crash feedback dialog won’t stay open for more than a spit second. All I get is the system crash report dialog.

I deleted the new version and pulled the previous one (3134) out of the trash, but it too crashes on launch, same exact behavior. I had just run this a few minutes earlier with no problem.

I also tried downloading the latest release version 3.1 (3133), but the same thing happens.

I tried restarting my Mac. No difference.

It seems like the installation procedure for the 3135 update messed up something that Glyphs depends on.

I’m running the latest macOS (12.5.1) on an M1 Mac.

Never mind. Somehow, repeatedly trying to start it, it’s working again. Some plug-ins seem to be at fault, maybe related to the vanilla thing people have been running into lately.

The restarts probably lead to the modules updating at one point. And that fixed it. For future reference: start the app with option & shift held down, which disables extensions (and prevents crashes caused by them). Then you can do stuff like uninstall and reinstall modules. Or selectively uninstall extensions to see if it is just one of them.

Okay, thanks. I couldn’t remember the shortcut for restarting the app without extensions. All is working now. Had to remove the Scrawl tool.

With the Scrawl Tool installed, I get this traceback when right-clicking (context menu):

GlyphsApp/GlyphsApp/plugins.py:93: UninitializedDeallocWarning: leaking an uninitialized object of type NSMenuItem
Traceback (most recent call last):
  File "GlyphsApp/GlyphsApp/plugins.py", line 1575, in defaultContextMenu
  File "GlyphsApp/GlyphsApp/plugins.py", line 93, in setUpMenuHelper
ValueError: depythonifying 'SEL', got 'method'

Not sure if the tool plugin is at fault?

I found and fixed the bug in Scrawl. I think you can safely reinstall it …

1 Like

Great—thanks!