Changes in UFO export since December '18?


#1

I was wondering if you changed anything the way UFO are written since last year ?

I am using UFOstretch to do make smallcaps or supp for example. UFOs exported in Dec '18 work fine. Now they don’t work anymore.


#2

I did some cross checking. I noticed it worked with the Roman file of the font. Not with the Italic. I then used another font I made in the past, Italic. And it worked as well. So big chance it is the file. I will send it to support.


#3

What version did you use the last time you exported the .ufos? Can you make a diff of the two ufos? I dont have ufostretch, so I can’t really test this.

I got your files, but could you send also a working ufo and the same ufo exported from the latest version?


#4

Actually, the file I am trying to get to work, is the Italic I sent you. The Roman always worked.
This is what I tried to do to solve it.

I started by exporting by the eldest version I have (1186).
Then I took out the Italic angle in the specs.
Then I took out the Italic angle and renamed it to Roman.

All failed in both version of Stretch I have. Normal+Beta.

To check if it was working, I took a completely different font and exported it as an Italic. Worked as a charm.

So I think the bug is in the file. Would there be a way to find this out, or to transfer everything to a “clean” file ?

J


#5

@GeorgSeifert Any idea ?


#6

I found a small problem and fixed it


#7

Sounds promising :slight_smile: