Changing UPM and Vertical Metrics


#1

I’m a novice so apologies in advance if my terminology isn’t right. I’ve designed a font with a small x-height and large ascender and descender heights. Because of the proportions of the font, it prints very small. Not a big deal I know, the point size can easily be increased, but previews for the font in Word and font management tools are tiny.

I’ve read the tutorials on setting custom parameters for the vertical metrics, but I think there is another/simpler option? I read on the forums here that I could decrease the UPM from the standard 1000. Is that the best way of tackling this problem?

Thanks in advance.


#2

Some apps have trouble with non-Standard UPMs, but only when the value becomes large, like above 3000. In your case, you are decreasing the value, so it should be fine. What I cannot spare you from is extensive testing in the apps you are aiming for, like MS Office.


#3

Thanks for this info!

Is this another option? …

Scale everything using the ‘Scale font to new UPM’ option to say 1500. I see that then increases the font size and the vertical metrics accordingly. Then set the units per Em back to 1000 prior to export?

I know that this has the effect of making very tight leading, but I think in this case its a choice of picking my poison?


#4

That sounds right.


#5

Thanks! Is there any way of scaling the spacing along with the UPM. I’m having to go through and rework all my spacing. Selecting across-the-board update metrics seems to screw everything up.


#6

Scale font to new UPM should take care of the spacing.


#7

Oh really? I reckon I’m doing something wrong here …

Example: My exclam was set prior to scaling the UPM to LSB =period+50 (80) and RSB period (40). I scaled the UPM from 1000 to 1740 so it makes sense that afterwards the spacing has changed to LSB =period+50 (140) and RSB period (70) (because 80 x 1.74 = 140 and 40 x 1.74 = 70). The LSB is red indicating that I need to update metrics. When I update the metrics, the LSB goes to =period+50 (102).


#8

The metrics keys are not scaled. But the metrics are correct. You have to ignore the Metrics key warnings.


#9

Ah gotcha. Thanks so much!


#10

Apologies, one last thing. I also notice that my kerning has gone fractional. For example, kerning that was +20 is now +34.7999992370605. I take it that matters not?


#11

It will be rounded on export.


#12

Thanks, much appreciated. I wouldn’t do it this way around again of course. My first font #steeplearningcurve!