Character widths/spacing changed after UPM conversion

A while ago I had issues with an SVG font, in which the spacing was acting strangely after exporting (while the preview in Glyphs was spot on). With Georg’s help the issue was fixed.

For use in Word and other simple text editors, I wanted to change the non-SVG version as well, but I ran into a problem. The main issue before was the UPM in which I made the typeface, so this had to be scaled to the standard 1000. But for some reason, when I scale the masters down, my character spacing is changed as well. This makes some glyphs merge into each other and dis-aligns the layering effects.

I’ve tried different methods of scaling down, and can’t seem to find a constant, each different way of scaling makes another glyph act up. Also: The issue only shows after exporting. In Glyphs all characters look fine.

The high UPM version exports fine though.

You should change the UPM by clicking the arrows button in Font Info > Font (next to the UPM field).

Yeah, that’s the way I converted the UPM. Most of the spacing converts fine, but (on exporting) some spacing runs into each other.

Since it’s all fine in the Glyphs file itself, even the layering, I have no way correct it, aside the (mystery for me) solution.

Are you sure the fonts are broken or do you have a font cache problem?

Yeah, I always use the Adobe “hot” font folder. Also, the preview of the .otf shows the issues. So does TextPreview.

Can you send me the .glyphs file?

It’s been a bit busy so I haven’t been able to try other things myself before today. I know some of the “faults” are shared between classes, but the weights in which they do seem to vary. (some weights with precisely the same sidebearings/widhts give different results.

Of course, due to the resizing the metrics aren’t really tidy, with a lot of decimal values. Might that perhaps solve the issue?