Component-based glyphs jump around in print

Which settings? There are a few I tend to avoid. Do not hint composites for example.

Which settings? I simply have “Autohint” ticked upon export.

Can you try without autohinting?

I’ll try tomorrow :slightly_smiling_face:

I have the same problem.
The dots that are loaded as components in the letters are moved in some printers.
How can I decompose them all when exporting?

@GeorgSeifert
In G3, I can filter instance by decompose component. But I made this font in G2.
Transferring it to G3 will also destroy the kerning!

How will opening it in G3 destroy the kerning?

It is not destroyed, but you do need to convert RTL kerning, which in Glyphs 3 is now separate from other directions. There is a mekkablue script for the exact purpose.

I assume this is a TTF export. Are you using TTF Autohint? And if so, with which settings?

I tried to fix the kerning with the mekkablue script in G3 but it does not work properly and some of the kerning still on the LTR.
We will have to rebuild all our previous fonts in G3 :frowning:

Yes, this is a TTF export. without hinting.

In G3 RTL kerning and LTR are stored in two separate tables. But in G2, both were on the same.

Can you send us the .glyphs file (and some examples that don’t work) that we can debug the script?

thanks, I sent the file to you.

You can add a “Decompose Glyphs” parameter and add all the dot glyphs that are made from components.

I’ll need to check if I can fix the problem by decomposing the nested components.

1 Like

How can I add this parameter in G2?
I did this at G3. But it was not possible in G2!

Should work the same way in Glyphs 2?



There is no “Decompose Glyphs” parameter in G2.

Start typing with an uppercase “D”.

1 Like

thank you :pray: :heart: